nodo-domotica.nl

De temperatuurwaarden verschijnen niet in de WebApp

Post hier vragen en ervaringen die betrekking hebben op het gebruik en configuratie van de WebApp

De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor jack » 05 sep 2014, 15:38

Na een lange tijd de draad weer opgepakt....

Dallas sensor aangesloten op de Nodo. Alle installatie stappen doorlopen. Maar de temperatuurwaarde in de WebApp blijft op 0 staan en verandert niet. Wat gaat er mis?
Hieronder de script:

Booting...
Initialising ethernet connection...

!******************************************************************************!
Nodo Domotica controller (c) Copyright 2014 P.K.Tonkes.
Licensed under GNU General Public License.
Nodo-Mega V3.7, Product=SWACNC-MEGA-R744, Home=1, ThisUnit=1, ID=C2606K7P
Date=05-09-2014 (Fri); Time=16:31 DaylightSaving
IP=192.168.2.238, PortOutput=80, PortInput=6636
Host=www.nodo-domotica.nl, HostIP=185.10.51.106
!******************************************************************************!
Output=HTTP(185.10.51.106); Unit=1; Event=Boot 1
Output=I2C; Unit=0; Event=Boot 1
Output=RF; Unit=0; Event=Boot 1
Input=System; Unit=1; Event=Boot 1
Input=Eventlist(1.1); Unit=1; Event=TimerSet 1,30

Ready. Nodo is waiting for serial input...

eventlistshow;
Input=Serial; Unit=1; Event=EventlistShow 0
!******************************************************************************!
1: Boot 1; TimerSet 1,30
2: Timer 1; TimerSet 1,30
3: Timer 1; TempRead 1,1
!******************************************************************************!
Input=Clock; Unit=1; Event=Timer 1
Input=Eventlist(1.2); Unit=1; Event=TimerSet 1,30
Input=Eventlist(1.3); Unit=1; Event=TempRead 1,1
Input=Plugin; Unit=1; Event=VariableSet 1,24.688
Input=System; Unit=1; Event=Variable 1,24.688
Input=Clock; Unit=1; Event=Timer 1
Input=Eventlist(1.2); Unit=1; Event=TimerSet 1,30
Input=Eventlist(1.3); Unit=1; Event=TempRead 1,1
Input=Plugin; Unit=1; Event=VariableSet 1,24.688
Input=System; Unit=1; Event=Variable 1,24.688

Mvg,
Jack
jack
 
Berichten: 59
Geregistreerd: 31 jul 2012, 13:02

Re: De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor manjh » 05 sep 2014, 16:58

Je moet beginnen met het initialiseren van de nodo vanuit de webapp.
daarna de statements toevoegen zoals je dat zelf wilt.
Hans
manjh
 
Berichten: 1172
Geregistreerd: 29 aug 2011, 14:39

Re: De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor jack » 05 sep 2014, 17:47

Hans,

Dat heb ik gedaan. Alle stappen volgens getting started doorlopen. Vanuit de WebApp de juiste instellingen ingevoerd (ip adres, poortnummer) en de communicatie met de Nodo getest. Dit verliep goed. Vervolgens via procedure uit Wiki (onder Dallas sensor) de value temperauur met variabele 1 aangemaakt.

Jack
jack
 
Berichten: 59
Geregistreerd: 31 jul 2012, 13:02

Re: De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor mvdbro » 06 sep 2014, 10:03

Je mist waarschijnlijk een regel in de eventlist:

Code: Selecteer alles
WildCard All,Variable,0; EventSend HTTP;
mvdbro
 
Berichten: 1092
Geregistreerd: 21 okt 2011, 12:06

Re: De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor jack » 06 sep 2014, 12:43

Martinus, dat was de bug!! :D

Ik heb het voorbeeld uit de Wiki gebruikt en daar staat niets over de eventregel die jij noemt:
http://www.nodo-domotica.nl/index.php/T ... as_DS18B20

Idee om dit in de Wiki aan te passen voor de "leken" onder ons?

Ik heb nu de volgende eventlist:
EventlistWrite; Boot 1; TimerSet 1,30
EventlistWrite; Timer 1; TimerSet 1,30
EventlistWrite; Timer 1; TempRead 1,1
EventlistWrite; WildCard All,Variable,0; EventSend HTTP

In de WebApp verschijnt de temperatuur tot op 3 cijfers achter de komma. Is dit te wijzigen tot 1 cijfer achter de komma?

Bedankt!

Jack
jack
 
Berichten: 59
Geregistreerd: 31 jul 2012, 13:02

Re: De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor mvdbro » 13 sep 2014, 09:50

jack schreef:Martinus, dat was de bug!! :D

Ik heb het voorbeeld uit de Wiki gebruikt en daar staat niets over de eventregel die jij noemt:
http://www.nodo-domotica.nl/index.php/T ... as_DS18B20

Idee om dit in de Wiki aan te passen voor de "leken" onder ons?

De wiki stelt:
Code: Selecteer alles
We gaan er vanuit dat de Mega Nodo correct is verbonden met de WebApp en dat alle events netjes in de WebApp zichtbaar zijn.

Volgens mij zou dat al het geval moeten zijn nadat de Nodo vers is geconfigureerd door de webapp?
mvdbro
 
Berichten: 1092
Geregistreerd: 21 okt 2011, 12:06

Re: De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor Huiscv » 19 jan 2015, 05:06

Ik zie mijn temperatuurwaardes wel in de eventlog, maar komen niet tevoorschijn in de webapp.
Dit heb ik wel werkend gehad, maar nu geen waardes.
Ook heb ik al meerdere keren opnieuw aangemaakt, niets helpt?

Dus, wat moet ik op de webapp resetten of zo?
Huiscv
 
Berichten: 6
Geregistreerd: 27 nov 2014, 21:11

Re: De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor Flippo765 » 19 jan 2015, 13:13

Als de waardes wel binnenkomen in de webapp(eventlist) dan kunnen volgens mij alleen de instellingen van de grafiek verkeerd zijn.

Controleer deze instellingen eens: Setup > Values.

- Input type
- Display
- In or Output
- Nodo Unit
- Variable/Wired-in poort
Flippo765
 
Berichten: 96
Geregistreerd: 24 nov 2011, 22:31

Re: De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor Huiscv » 19 jan 2015, 18:53

Ik heb de instellingen gedaan zoals in de WIKI staat
(wel staat ih het voorbeeld, dat het een input is, maar dat moet vlgs mij een output zijn Output: Nodo > WebApp)

Dit is mijn eventist ook uit de wiki
Code: Selecteer alles
EventlistErase

EventlistWrite; WildCard RF,All,0; EventSend HTTP
EventlistWrite; WildCard IR,All,0; EventSend HTTP
EventlistWrite; WildCard System,Variable,0; EventSend HTTP
EventlistWrite; WildCard Wired,All,0; EventSend HTTP
EventlistWrite; WildCard HTTP,UserEvent,0; EventSend HTTP
EventlistWrite; WildCard All,Variable,0; EventSend HTTP
EventlistWrite; Boot 1; TimerSet 1,300
EventlistWrite; Timer 1; TimerSet 1,300
EventlistWrite; Timer 1; TempRead 1,1
EventlistWrite; Boot 2; UserEvent 1,1
EventlistWrite; Timer 1; LCDWrite 2,1,-,0
EventlistWrite; Timer 1; VariableInc 2,1
EventlistWrite; Timer 1; UserEvent 1,1
EventlistWrite; Variable 2,1; LCDWrite 1,1,-,0
EventlistWrite; Variable 2,1; UserEvent 1,2
EventlistWrite; Variable 2,1; LCDWrite 2,1,Clock,0
EventlistWrite; Variable 2,2; LCDWrite 2,1,IP,0
EventlistWrite; Variable 2,3; LCDWrite 1,1,-,0
EventlistWrite; Variable 2,3; LCDWrite 1,1,Message,9
EventlistWrite; Variable 2,3; LCDWrite 2,1,Message,19
EventlistWrite; Variable 2,3; LCDWrite 2,1,Variable,1
EventlistWrite; Variable 2,3; VariableSet 2,0
EventlistWrite; UserEvent 1,1; TimerSet 1,15
EventlistWrite; UserEvent 1,2; LCDWrite 1,1,Message,1


dit is de eventlog
Code: Selecteer alles

Unit    Event    Timestamp
1    Variable 2,2   2015-01-19 18:46:35   
1    Variable 2,2   2015-01-19 18:46:35   
1    Variable 1,21.563   2015-01-19 18:46:52   
1    Variable 1,21.563   2015-01-19 18:46:52   



Dus wat blijft er nu nog over?
Huiscv
 
Berichten: 6
Geregistreerd: 27 nov 2014, 21:11

Re: De temperatuurwaarden verschijnen niet in de WebApp

Berichtdoor kabouter » 19 jan 2015, 22:21

Huiscv schreef:Dus wat blijft er nu nog over?


Volgens mij mis ik nog een
Code: Selecteer alles
EventlistWrite; Timer 1; VariableSend 2,http
in de code
want je schrijft het wel naar het display maar niet naar de webapp.
kabouter
 
Berichten: 214
Geregistreerd: 10 nov 2011, 13:57

Volgende

Keer terug naar Nodo WebApp

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers. en 0 gasten

cron