nodo-domotica.nl

NES raakt tijd kwijt

Voor hulp om je Nodo aan de praat te krijgen

Re: NES raakt tijd kwijt

Berichtdoor avdl72 » 11 mei 2014, 12:02

De clock functie wordt al niet mee gecompileerd in de NSM.

De NSM op 5v werkt niet omdat er dan te weinig spanning is voor de aangesloten sensoren.
De NES op 5v geeft als resultaat dat RF niet goed zend en ontvangt.

Ik gebruik de universele voeding uit de webshop en heb gemerkt dat deze ongeveer 0,5v minder levert dan waar hij op ingesteld is. 5v is dan 4,5v.
http://www.nodo-shop.nl/nl/voedingen/5-universele-voeding-3-12v-5412810136711.html

Vrijdag de beide voedingen van NES en NSM op 9v gezet en dat heeft er voor gezorgd dat de tijd 2 dagen goed bleef. Vanochtend was die weer naar 2040 gegaan.
Ik heb de voedingen nu op 12v gezet om te kijken of dit beter gaat.
Nodo-Mega V3.7 R744
Web App version: SWINWA-PROD-V099 - lokaal
Nodo Ethernet Shield v2.0.2
Nodo Small v2.0.0 - t.b.v. Gas-, Water- en Stroommeter
Nodo Small v2.0.0 - t.b.v. KAKU
Nodo Mini - t.b.v. Temperatuur (Arduino Pro Mini)
avdl72
 
Berichten: 114
Geregistreerd: 29 nov 2012, 15:50

Re: NES raakt tijd kwijt

Berichtdoor avdl72 » 11 mei 2014, 21:27

Voeding op 12v maakt het erger. De tijd is nu alweer versprongen. :oops:

Zojuist de NES aangesloten op de 5v USB van de router.

Hopelijk geeft dit een beter resultaat, want anders weet ik niet wat er met Nodo gaat gebeuren :x
Nodo-Mega V3.7 R744
Web App version: SWINWA-PROD-V099 - lokaal
Nodo Ethernet Shield v2.0.2
Nodo Small v2.0.0 - t.b.v. Gas-, Water- en Stroommeter
Nodo Small v2.0.0 - t.b.v. KAKU
Nodo Mini - t.b.v. Temperatuur (Arduino Pro Mini)
avdl72
 
Berichten: 114
Geregistreerd: 29 nov 2012, 15:50

Re: NES raakt tijd kwijt

Berichtdoor avdl72 » 12 mei 2014, 17:37

En ook via de USB stroomvoorziening is de NES zijn tijd weer kwijt.

Sinds vanmiddag staat de tijd weer op:
ClockSetDate 09-14-2040
ClockSetTime 00:00

Wat me wel opvalt is dat bij 9v en 12v de ClockSetTime wel door liep en niet op 00:00 bleef staan net als nu.
Nodo-Mega V3.7 R744
Web App version: SWINWA-PROD-V099 - lokaal
Nodo Ethernet Shield v2.0.2
Nodo Small v2.0.0 - t.b.v. Gas-, Water- en Stroommeter
Nodo Small v2.0.0 - t.b.v. KAKU
Nodo Mini - t.b.v. Temperatuur (Arduino Pro Mini)
avdl72
 
Berichten: 114
Geregistreerd: 29 nov 2012, 15:50

Re: NES raakt tijd kwijt

Berichtdoor avdl72 » 12 mei 2014, 17:42

In mijn vorige bericht van 18:37 staat de NES tijd op:
ClockSetDate 09-14-2040
ClockSetTime 00:00

Meteen na het plaatsen van het bericht heb ik de NES weer aangesloten op de 9v voeding en nu staat de tijd op:
ClockSetDate 09-14-2040
ClockSetTime 01:20

Dit is echt vreemd :?

Wat ook opvalt is dat ik geen ClockSync HTTP kan uitvoeren als de datum/tijd verkeerd staat.
Ik moet dan eerst de datum goedzetten, een reboot uitvoeren en pas dan een sync uitvoeren.
Nodo-Mega V3.7 R744
Web App version: SWINWA-PROD-V099 - lokaal
Nodo Ethernet Shield v2.0.2
Nodo Small v2.0.0 - t.b.v. Gas-, Water- en Stroommeter
Nodo Small v2.0.0 - t.b.v. KAKU
Nodo Mini - t.b.v. Temperatuur (Arduino Pro Mini)
avdl72
 
Berichten: 114
Geregistreerd: 29 nov 2012, 15:50

Re: NES raakt tijd kwijt

Berichtdoor rwijbenga » 13 mei 2014, 22:05

Een andere Arduino mega proberen misschien? Anders zou Paul een keer met wat suggesties moeten komen......
rwijbenga
 
Berichten: 344
Geregistreerd: 28 aug 2011, 14:58

Re: NES raakt tijd kwijt

Berichtdoor avdl72 » 14 mei 2014, 06:13

Ik kan wel een andere Arduino Mega gaan kopen, maar in versie 3.6 heb ik zonder problemen I2C kunnen gebruiken.
Dus ik denk dat ik komend weekend eerst 3.6 er op ga zetten om te kijken of het probleem er dan nog is.
Nodo-Mega V3.7 R744
Web App version: SWINWA-PROD-V099 - lokaal
Nodo Ethernet Shield v2.0.2
Nodo Small v2.0.0 - t.b.v. Gas-, Water- en Stroommeter
Nodo Small v2.0.0 - t.b.v. KAKU
Nodo Mini - t.b.v. Temperatuur (Arduino Pro Mini)
avdl72
 
Berichten: 114
Geregistreerd: 29 nov 2012, 15:50

Re: NES raakt tijd kwijt

Berichtdoor henkdejonge » 14 mei 2014, 09:13

Hi,

Is het misschien het batterijtje wat op de NES zit?
Afbeelding
henkdejonge
 
Berichten: 102
Geregistreerd: 21 maart 2012, 16:29

Re: NES raakt tijd kwijt

Berichtdoor avdl72 » 14 mei 2014, 10:26

Batterijtje is in orde, en ook al een keer vervangen.
Deze geeft de spanning die benodigd is, en de spanning is ook tot aan de clock chip te volgen.
Nodo-Mega V3.7 R744
Web App version: SWINWA-PROD-V099 - lokaal
Nodo Ethernet Shield v2.0.2
Nodo Small v2.0.0 - t.b.v. Gas-, Water- en Stroommeter
Nodo Small v2.0.0 - t.b.v. KAKU
Nodo Mini - t.b.v. Temperatuur (Arduino Pro Mini)
avdl72
 
Berichten: 114
Geregistreerd: 29 nov 2012, 15:50

Re: NES raakt tijd kwijt

Berichtdoor manjh » 14 mei 2014, 10:43

Het lijkt mij sterk dat het aan de software ligt. Ik heb hier een Mega met NES op mijn buro liggen, die gebruik ik voor testen. Het ding draait al tijden zonder problemen. Er zit een LCD op die periodiek onder meer tijd en datum toont, precies goed. LCD is aangesloten via I2C.
Bovendien hebben vele Nodo-isten de NES met de jongste release draaien, en ik zie weinig problemen. Dit moet echt exemplarisch zijn.
Bekijk de print van de Mega en de NES eens zorgvuldig. Zijn er beschadigingen te zien? kun je iets zien aan de soldeerverbingingen? (je wilt niet weten hoeveel tijd ik over de jaren heen heb verspild aan het zoeken naar een koude las... :-( )
Hans
manjh
 
Berichten: 1172
Geregistreerd: 29 aug 2011, 14:39

Re: NES raakt tijd kwijt

Berichtdoor henkdejonge » 14 mei 2014, 12:02

avdl72 schreef:Ik kan wel een andere Arduino Mega gaan kopen, maar in versie 3.6 heb ik zonder problemen I2C kunnen gebruiken.
Dus ik denk dat ik komend weekend eerst 3.6 er op ga zetten om te kijken of het probleem er dan nog is.


Hi,

Hier koop je ze voor net €10,-

http://www.ebay.nl/itm/1PCS-ATMEGA2560- ... 41c&_uhb=1

Suc6.
Afbeelding
henkdejonge
 
Berichten: 102
Geregistreerd: 21 maart 2012, 16:29

VorigeVolgende

Keer terug naar Nodo aan de praat krijgen

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers. en 2 gasten

cron