nodo-domotica.nl
http://www.nodo-domotica.nl/forum/

Datum en tijdstip raken corrupt?...
http://www.nodo-domotica.nl/forum/viewtopic.php?f=8&t=2225
« Vorige  Pagina 2 van 2
Auteur:  Sjoerdp [ 17 nov 2014, 10:01 ]
Titel:  Re: Datum en tijdstip raken corrupt?...

Ik heb precies hetzelfde met mijn Mega2560 R3 (origineel) in combinatie met een zelf gesoldeerde Nodo print. Vorige week een keer de stroom eraf gehad en sindsdien problemen. De tijd loopt inderdaad niet meer als ik hem handmatig instel. En ook de ClockSync werkt niet.

Moet binnenkort maar eens gaan bug hunten, maar heb geen reserve Nodo Mega :-(
Auteur:  Sjoerdp [ 17 nov 2014, 22:05 ]
Titel:  Re: Datum en tijdstip raken corrupt?...

En bij mij is het opgelost. Een aantal contactjes opnieuw gesoldeerd en ik denk dat het een aarde probleem was, aangezien ik bij een beetje wiebelen met de draadjes de speaker elke seconde een klein tikje hoorde geven.... Kijk je print dus even goed na!
Auteur:  ralph [ 17 nov 2014, 22:09 ]
Titel:  Re: Datum en tijdstip raken corrupt?...

Na het vervangen van de Mega 2560 door de Mega 1280 leek het probleem verholpen.
Leek, want enkele dagen later begon de grap zich te herhalen.

Na de opmerking van rwijbenga heb ik direct DS1307 besteld.
http://www.nodo-domotica.nl/index.php/Nodo-shield

Hoopte natuurlijk dat ik de RTC chip niet hoefde te vervangen, maar helaas...
Afgelopen weekend was het dan zover dat ik met mijn boutje en een handmatige tinzuiger aan de slag ging.
Dat ging alles..., behalve gemakkelijk.

"Rust kan je redden...", "geen geweld gebruiken...", "diep ademen..." dat waren zo de woorden die door mijn hoofd spookten.
Ik was bang om de print en componenten teveel te verhitten... met als resultaat losse busjes, et cetera.

Uiteindelijk gepast geweld gebruikt en de pootjes, zo dicht mogelijk tegen het chip lichaam, doorgeknipt.
Daarna ging het vlotjes, aan een zijde van de print verhitten en aan de andere zijde de tin zuiger zijn werk laten doen.

IC voetje gemonteerd (mocht de nieuwe chip het ooit begeven dan wil je dit niet nog een keer meemaken), DS1307 erin en batterij geplaatst.
Op dit moment draait mijn Nodo alweer twee dagen.
Lijkt zelfs vlotter te reageren, maar dat kan de invloed van mijn 'blijheid' zijn.

Overigens best wel aardig om te ervaren hoe je ongemerkt van de rijkheid van een Nodo afhankelijk kan zijn geworden 8-)
Auteur:  rwijbenga [ 18 nov 2014, 12:43 ]
Titel:  Re: Datum en tijdstip raken corrupt?...

Helemaal top ! 8-)
Auteur:  TeamKleijn [ 25 maart 2015, 23:52 ]
Titel:  Re: Datum en tijdstip raken corrupt?...

Sinds vanmorgen lijkt het toch weer fout te gaan.
Een 'status all' laat o.a. het volgende opvallende resultaat zien:

ClockSetDate 45-45-2165
ClockSetTime 44:85

Iemand enig idee wat de oorzaak van de vreemde tijd- en datumwaarde kan zijn?


Ik had dit probleem vandaag ook precies zoals hier boven ook in de quote staat afgebeeld.
Een reboot en een ClockSync HTTP gaf het effect dat er een fatsoenlijke tijd wordt weergegeven in de status. Die tijd loopt weliswaar 1 uur achter (ahum zomertijd komt dit weekend toch pas)

Nu die clock nog 'recht' krijgen, dan kan ik meemaken dat de naar Zomertijd omschakeling goed uitvoert ...

Met vriendelijke groeten,

"Team Kleijn"
Rob

[Tracking] http://www.trackr.nl/user/TeamKleijn/live/
Auteur:  TeamKleijn [ 29 aug 2015, 13:19 ]
Titel:  Re: Datum en tijdstip raken corrupt?...

Hmmm, heb dit probleem ook en maar liefst op allebei mijn Nodo's
heb het Eventscript teruggebracht naar alleen een paar tijdgerelateerde zaken. Laat nu 1 keer per 10 minuten een Event genereren welke een berichtje op mijn telefoon geeft.

ClockSyncHttp zou wel eens de oorzaak kunnen zijn.
Nu even uitgezet en kijken of mijn TestNodo de tijd vasthoudt en blijft doorlopen

Rob
TeamKleijn
Auteur:  ralph [ 17 okt 2015, 16:54 ]
Titel:  Re: Datum en tijdstip raken corrupt?...


Lees nu pas dit bericht.
Ben je er nog uitgekomen? Wat was bij jou de oorzaak?
In mijn geval was het de eerste keer de chip, de tweede storing bleek te wijten aan een end-of-live voeding ;)
Auteur:  henkdejonge [ 23 okt 2015, 10:30 ]
Titel:  Re: Datum en tijdstip raken corrupt?...

ralph schreef:
Lees nu pas dit bericht.
Ben je er nog uitgekomen? Wat was bij jou de oorzaak?
In mijn geval was het de eerste keer de chip, de tweede storing bleek te wijten aan een end-of-live voeding ;)


Ik heb laatst contact gehad met "Team Klein" deze heeft de voedingen vervangen en nadien geen problemen meer gehad. Dus probeer dat eens.

Grtz, henk.
Pagina 2 van 2 Alle tijden zijn GMT + 1 uur