nodo-domotica.nl

Datum en tijdstip raken corrupt?...

Hier alles over de Software in de Nodo

Datum en tijdstip raken corrupt?...

Berichtdoor ralph » 20 okt 2014, 18:42

De apparatuur wordt helaas niet meer naar wens in- en uitgeschakeld.
Script opnieuw laden mocht niet baten, waarna een reset is doorgevoerd.
Nadat het script was ingelezen liep de trouwe Nodo weer als vanouds.

In het script wordt de RTC iedere zondag met de webserver van het Nodo-team gesynchroniseerd.
EventlistWrite; Time 00:00, Sun; ClockSync HTTP
Handmatig "ClockSync HTTP' invoeren geeft normale waarden als resultaat.

Sinds vanmorgen lijkt het toch weer fout te gaan.
Een 'status all' laat o.a. het volgende opvallende resultaat zien:

ClockSetDate 45-45-2165
ClockSetTime 44:85

Iemand enig idee wat de oorzaak van de vreemde tijd- en datumwaarde kan zijn?
Nodo-Mega V3.7 - R744
Nodo Shield V1.2.2 + Nodo Koppelprint
Arduino Mega 1280 + Ethernet Shield Wiznet W5100
Logitech Harmony Touch en DHT-22
ralph
 
Berichten: 70
Geregistreerd: 29 dec 2011, 13:11

Re: Datum en tijdstip raken corrupt?...

Berichtdoor ralph » 22 okt 2014, 09:08

Aanvulling op eerste bericht.

Vandaag gezien dat de clock nog steeds op datum en tijdstip van mijn voorgaande bericht staat?!
Batterij gecontroleerd, deze geeft 3.330 V af.

Na terug plaatsen batterij geeft 'status all' via webapp in relatie tot de clock:
ClockSetDate 00-00-0000
ClockSetTime 00:00

Netwerkconnectie gecontroleerd en werkend.

Vervolgens via webapp 'clocksync http' gegeven, resultaat:
Input=HTTP(185.10.48.55); Unit=1; Event=ClockSync

Commando 'status all' via webapp blijft als resultaat geven:
ClockSetDate 00-00-0000
ClockSetTime 00:00

Kennelijk lijkt synchronisatie met de klok van de webserver niet te werken.

Commando 'clocksetdate 22-10-2014' via webapp geeft als resultaat:
Input=HTTP(185.10.48.55); Unit=1; Event=ClockSetDate 22-10-2014

Commando 'status all' via webapp geeft nu:
ClockSetDate 22-10-2014
ClockSetTime 00:00

Commando 'clocksettime 09.52' via webapp geeft als resultaat:
Input=HTTP(185.10.48.55); Unit=1; Event=ClockSetTime 09:52

Commando 'status all' via webapp geeft nu:
ClockSetDate 22-10-2014
ClockSetTime 09:52

Herhaling - op later tijdstip - van commando 'status all' via webapp blijft als resultaat geven:
ClockSetDate 22-10-2014
ClockSetTime 09:52

De clock staat 'stil'?

Ik stel het zeer op prijs als iemand kan adviseren hoe verder te handelen.
WAF lijkt anders het huidige weertype te volgen... :(
Nodo-Mega V3.7 - R744
Nodo Shield V1.2.2 + Nodo Koppelprint
Arduino Mega 1280 + Ethernet Shield Wiznet W5100
Logitech Harmony Touch en DHT-22
ralph
 
Berichten: 70
Geregistreerd: 29 dec 2011, 13:11

Re: Datum en tijdstip raken corrupt?...

Berichtdoor rwijbenga » 22 okt 2014, 20:42

De klok heeft altijd gewerkt ?

Het is geen NES print toch? In je handtekening staat nodo shield met koppel print.

Anders eens de nodo software er opnieuw inladen, als dat ook niet werkt kan het zijn dat je klok chip defect is, die is op een nodo shield makkelijk te vervangen.. ( 8 pins chip ) Of een probleem met de i2c bus.
rwijbenga
 
Berichten: 344
Geregistreerd: 28 aug 2011, 14:58

Re: Datum en tijdstip raken corrupt?...

Berichtdoor ralph » 22 okt 2014, 20:54

Dank voor jouw reactie!
Ja, de klok heeft altijd netjes gewerkt.
Mijn handtekening is actueel, dus inderdaad de oude vertrouwde Nodo shield met koppel print.
Morgen zal ik de software opnieuw laden en dan duimen dat dit het is.
Anders met gepast geweld de soldaatbout inzetten...
Ik houd jullie hier op de hoogte van dit avontuur ;)
Nodo-Mega V3.7 - R744
Nodo Shield V1.2.2 + Nodo Koppelprint
Arduino Mega 1280 + Ethernet Shield Wiznet W5100
Logitech Harmony Touch en DHT-22
ralph
 
Berichten: 70
Geregistreerd: 29 dec 2011, 13:11

Re: Datum en tijdstip raken corrupt?...

Berichtdoor manjh » 22 okt 2014, 22:43

Voordat je de software gaat laden even een reset... ik weet niet of het helpt, maar het kan zeker geen kwaad.
Hans
manjh
 
Berichten: 1172
Geregistreerd: 29 aug 2011, 14:39

Re: Datum en tijdstip raken corrupt?...

Berichtdoor ralph » 22 okt 2014, 22:45

Ga ik nu zeker doen.
Dank voor jouw tip!
Nodo-Mega V3.7 - R744
Nodo Shield V1.2.2 + Nodo Koppelprint
Arduino Mega 1280 + Ethernet Shield Wiznet W5100
Logitech Harmony Touch en DHT-22
ralph
 
Berichten: 70
Geregistreerd: 29 dec 2011, 13:11

Re: Datum en tijdstip raken corrupt?...

Berichtdoor ralph » 27 okt 2014, 22:21

OPGELOST!
Bovenstaande tips opgevolgd en mijn Nodo werkt weer als vanouds :D
Dank voor het meedenken en het aanreiken van de oplossing...
Nodo-Mega V3.7 - R744
Nodo Shield V1.2.2 + Nodo Koppelprint
Arduino Mega 1280 + Ethernet Shield Wiznet W5100
Logitech Harmony Touch en DHT-22
ralph
 
Berichten: 70
Geregistreerd: 29 dec 2011, 13:11

Re: Datum en tijdstip raken corrupt?...

Berichtdoor ralph » 02 nov 2014, 21:24

Te vroeg gejuicht :o
Vandaag bleef alles weer 'hangen'.

Status All geeft:
ClockSetDate 45-45-2165
ClockSetTime 24:05

Zal het dan toch, zoals eerder opgemerkt, de RTC chip zijn?
Zijn er nog andere zaken te checken voordat ik de soldeerbout pak?
Nodo-Mega V3.7 - R744
Nodo Shield V1.2.2 + Nodo Koppelprint
Arduino Mega 1280 + Ethernet Shield Wiznet W5100
Logitech Harmony Touch en DHT-22
ralph
 
Berichten: 70
Geregistreerd: 29 dec 2011, 13:11

Re: Datum en tijdstip raken corrupt?...

Berichtdoor ralph » 11 nov 2014, 21:48

UPDATE
De rode LED bleef op een gegeven moment branden en Nodo reageerde nergens meer op.
Ook DHT-22 variabelen werden niet meer verzonden en zelfs het contact met de WebApp werd verbroken en was niet te herstellen.

Arduino overschreven met blink sketch, welke werkte.
Vervolgens overschreven met Nodo versie 3.7, gevolgd door een reset, het laden van mijn script en een reboot.
Verschijnselen bleven...

'Oude' - maar blijkbaar trouwe - Arduino Mega 1280 (kloon) weer ingezet en... geen enkel probleem meer.
Zelfs de RTC werkt weer normaal?!
Even aankijken of het goed blijft gaan.

De Arduino Mega 2560 R3 (origineel) lijkt in andere projecten gewoon goed te functioneren.
Ik weet dus niet waar nu de fout ligt, terwijl het altijd heeft gewerkt en aan de configuratie niets is veranderd.

Weet iemand of er zoiets als een Arduino functionaliteit testprogramma bestaat?
Nodo-Mega V3.7 - R744
Nodo Shield V1.2.2 + Nodo Koppelprint
Arduino Mega 1280 + Ethernet Shield Wiznet W5100
Logitech Harmony Touch en DHT-22
ralph
 
Berichten: 70
Geregistreerd: 29 dec 2011, 13:11

Re: Datum en tijdstip raken corrupt?...

Berichtdoor rwijbenga » 11 nov 2014, 23:04

Ik heb zelf nog niet echt een test code gevonden, maar het kan ook een combinatie probleem zijn....
Als het goed nu werkt niet meer te lang over nadenken... ;)
rwijbenga
 
Berichten: 344
Geregistreerd: 28 aug 2011, 14:58

Volgende

Keer terug naar Nodo Software

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers. en 2 gasten

cron