nodo-domotica.nl

WebApp code beschikbaar

Post hier vragen en ervaringen die betrekking hebben op het gebruik en configuratie van de WebApp

Re: WebApp code beschikbaar

Berichtdoor kabouter » 22 apr 2015, 19:35

mdegraaf schreef:
kabouter schreef:zover ik weet kan ik dat wel van binnenuit benaderen heb ook nog andere port mapping staan zoals Domotics en andere apps en IP camera's .
maar ik weet zo niet of het aan de Synology 212J nas kan liggen.


Als ik de pagina http://vanderaa.dyndns.tv/webapp/api/ open zie ik de tekst "Goeden avond, welkom bij Kabouterhuis" hier gaat in ieder geval iets mis. Indien je de pagina http://vanderaa.dyndns.tv/webapp opent krijg je dan een login pagina te zien?


Zo te zien kom ik dus met http://vanderaa.dyndns.tv/webapp/api/ in mijn hoofdpagina uit.
dus zou ik alles in de root moeten plaatsen. ( liever niet.)
Als ik http://vanderaa.dyndns.tv/webapp open kom ik inderdaad gewoon bij het inlog pagina.
kan ik dit opvangen door in path.js deze pad aan te geven ?


heb path.js aangepast en nu laat ie met http://vanderaa.dyndns.tv/webapp/api/ bij mij wel iets anders zie.API commands ... lijkt nu wel goed te gaan.
Nu nog ff wat hobby-en met het een en ander. of zit ik nu op een verkeerde spoor? :oops:
kabouter
 
Berichten: 214
Geregistreerd: 10 nov 2011, 13:57

Re: WebApp code beschikbaar

Berichtdoor Vincent » 22 apr 2015, 20:21

mdegraaf schreef:
Vincent schreef:
mdegraaf schreef:Hoi Andreo,

Zorg in ieder geval dat je de rewrite en headers module in apache laad en onder php de curl extensie aanstaat.

Mocht het hierna nog niet lukken dan stel ik even een testplannetje op zodat we kunnen achterhalen wat de oorzaak van je probleem is.


Martin,

Ben hier opnieuw vanaf 0 begonnen op de RPI met de nieuwe versie en jouw stappenplan. Helaas is het resultaat precies hetzelfde dan bij Andreo (en dus zoals in de screenshot die ik eerder postte).

Zelf werk ik met Lighttpd ipv Apache. Ik zie dat curl en rewrite enabled zijn, maar ik vind nergens terug hoe ik onder Lighttpd de module headers kan activeren ... Zou het gebrek aan die headers module het probleem zijn ? Kan je mij/ons op weg helpen om deze alsnog te activerenninder Lighttpd ?

Dank en groeten,
Vincent.

Edit: op aangeven van onderstaande site mod_setenv geactiveerd ... zonder resultaat ...

http://wiki.nginx.org/ModuleComparisonMatrix


Hoi Vincent,

Lighthttpd heb ik zelf geen ervaring mee maar de Web App is in ieder geval afhankelijk van /api met daarin de .htaccess config. De headers module wordt in het geval van de Web App gebruikt voor CORS. Met andere woorden, de API kan ook vanaf externe locaties worden benaderd. Mocht het probleem aan de headers module liggen dan kun je deze afhankelijkheid uitschakelen door onderstaande stappen uit te voeren.

1) open .htaccess in de map /api
2) zet een # voor of verwijder de regels
Header add Access-Control-Allow-Origin "*"
Header add Access-Control-Allow-Headers "origin, x-requested-with, content-type, authorization"
Header add Access-Control-Allow-Methods "PUT, GET, POST, DELETE, OPTIONS"
3) open index.php in de map /api
4) verwijder regels 3 t/m 11 (zie onderstaande code)
if ($_SERVER['REQUEST_METHOD'] == 'OPTIONS') {
// return only the headers and not the content
// only allow CORS if we're doing a GET - i.e. no saving for now.
if (isset($_SERVER['HTTP_ACCESS_CONTROL_REQUEST_METHOD']) && $_SERVER['HTTP_ACCESS_CONTROL_REQUEST_METHOD'] == 'GET') {
header('Access-Control-Allow-Origin: *');
header('Access-Control-Allow-Headers: origin, x-requested-with, content-type, authorization');
}
exit;
}


Dank voor het antwoord. Heb het zo geprobeerd maar het verandert helaas niets. Ik blijf het scherm met bovenaan "undefined" krijgen (cfr screenshot die ik postte) ...
Tenzij iemand iets beter kan bedenken zal ik eens lighttpd vervangen door apache op de RPI ...
Vincent
 
Berichten: 26
Geregistreerd: 17 feb 2015, 22:05

Re: WebApp code beschikbaar

Berichtdoor andreo » 22 apr 2015, 21:12

Martin,

De nieuwe webapp versie draait nu lokaal op een QNap na de aanpassing van de mod_headers, nu heb ik geprobeerd een NES via een automatische config te koppelen met de webapp echter zonder succes.
Uiteindelijk heb ik de NES geprogrammeerd met de laatste Nodo software op github (3.8 build 809) en het nogmaals via de auto config procedure geprobeerd, na het invullen van het Nodo IP adres en een wachtwoord en het vinkje Auto Config wordt de NES geprogrammeerd (dit kan ik zien via een putty sessie op het LAN) en dan geeft de webapp aan dat de registratie correct is verlopen echter blijft er in de webapp staan dat er GEEN connect met de NES is.

Hieronder een weergave van status all
Code: Selecteer alles
!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R809, ThisUnit=1, ID=DR8AWT1K
Date=22-04-2015 (Wed); Time=22:07 DaylightSaving
IP=192.168.1.74, PortOutput=80, PortInput=6636
Host=qnap.local
!******************************************************************************!
>Input=System; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.
Output=HTTP; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.

>>status all
Input=Terminal; Unit=1; Event=Status All,0

!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R809, ThisUnit=1, ID=DR8AWT1K
Date=22-04-2015 (Wed); Time=22:08 DaylightSaving
IP=192.168.1.74, PortOutput=80, PortInput=6636
Host=qnap.local
!******************************************************************************!
AlarmSet 1,Off,00:00,*
AlarmSet 2,Off,00:00,*
AlarmSet 3,Off,00:00,*
AlarmSet 4,Off,00:00,*
AlarmSet 5,Off,00:00,*
AlarmSet 6,Off,00:00,*
AlarmSet 7,Off,00:00,*
AlarmSet 8,Off,00:00,*
ClientIP 0.0.0.0.255
ClockDaylight 4,0
ClockSetDate 22-04-2015
ClockSetTime 22:08
Debug Off
Plugin 1
Plugin 2
EventlistCount 5,250
FreeMem 2434
HWConfig 0x400BE737
HWStatus 0x4003E337
HTTPHost qnap.local/nodo/nodo.php
ID DR8AWT1K
IP 0.0.0.0.0(DHCP)
Log Off
Output HTTP,On
PortInput 6636
PortOutput 80
RawSignalReceive Off,On
Temp
WiredAnalog 1,1022
WiredAnalog 2,1022
WiredAnalog 3,1022
WiredAnalog 4,1022
WiredAnalog 5,1022
WiredAnalog 6,1022
WiredAnalog 7,1022
WiredAnalog 8,1022
WiredIn 1,On
WiredIn 2,On
WiredIn 3,On
WiredIn 4,On
WiredIn 5,On
WiredIn 6,On
WiredIn 7,On
WiredIn 8,On
WiredOut 1,Off
WiredOut 2,Off
WiredOut 3,Off
WiredOut 4,Off
WiredOut 5,Off
WiredOut 6,Off
WiredOut 7,Off
WiredOut 8,Off
WiredPullup 1,On
WiredPullup 2,On
WiredPullup 3,On
WiredPullup 4,On
WiredPullup 5,On
WiredPullup 6,On
WiredPullup 7,On
WiredPullup 8,On
WiredSmittTrigger 1,10
WiredSmittTrigger 2,10
WiredSmittTrigger 3,10
WiredSmittTrigger 4,10
WiredSmittTrigger 5,10
WiredSmittTrigger 6,10
WiredSmittTrigger 7,10
WiredSmittTrigger 8,10
WiredThreshold 1,512
WiredThreshold 2,512
WiredThreshold 3,512
WiredThreshold 4,512
WiredThreshold 5,512
WiredThreshold 6,512
WiredThreshold 7,512
WiredThreshold 8,512
RawSignalSample 25
AliasShow Off
Build 809
WaitBusyNodo Off
!******************************************************************************!


Dit is wat ik continu in putty zie verschijnen
    >>Input=System; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.
    Output=HTTP; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.

Heb je mogelijk een idee welke instelling er mis gaat wat betreft communicatie??
Groet, Andre
mijn NES
Nodo-Mega V3.7 R744|Nodo-Mini V3.7 R744|WebApp lokaal QNAP TS-119P II (SWINWA-PROD-V099)|WS-3500|ASUN650 zonweringsmodule | diverse KAKU |
andreo
 
Berichten: 119
Geregistreerd: 17 sep 2012, 23:51
Woonplaats: Anna Paulowna

Re: WebApp code beschikbaar

Berichtdoor mdegraaf » 22 apr 2015, 21:53

andreo schreef:Martin,

De nieuwe webapp versie draait nu lokaal op een QNap na de aanpassing van de mod_headers, nu heb ik geprobeerd een NES via een automatische config te koppelen met de webapp echter zonder succes.
Uiteindelijk heb ik de NES geprogrammeerd met de laatste Nodo software op github (3.8 build 809) en het nogmaals via de auto config procedure geprobeerd, na het invullen van het Nodo IP adres en een wachtwoord en het vinkje Auto Config wordt de NES geprogrammeerd (dit kan ik zien via een putty sessie op het LAN) en dan geeft de webapp aan dat de registratie correct is verlopen echter blijft er in de webapp staan dat er GEEN connect met de NES is.

Hieronder een weergave van status all
Code: Selecteer alles
!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R809, ThisUnit=1, ID=DR8AWT1K
Date=22-04-2015 (Wed); Time=22:07 DaylightSaving
IP=192.168.1.74, PortOutput=80, PortInput=6636
Host=qnap.local
!******************************************************************************!
>Input=System; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.
Output=HTTP; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.

>>status all
Input=Terminal; Unit=1; Event=Status All,0

!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R809, ThisUnit=1, ID=DR8AWT1K
Date=22-04-2015 (Wed); Time=22:08 DaylightSaving
IP=192.168.1.74, PortOutput=80, PortInput=6636
Host=qnap.local
!******************************************************************************!
AlarmSet 1,Off,00:00,*
AlarmSet 2,Off,00:00,*
AlarmSet 3,Off,00:00,*
AlarmSet 4,Off,00:00,*
AlarmSet 5,Off,00:00,*
AlarmSet 6,Off,00:00,*
AlarmSet 7,Off,00:00,*
AlarmSet 8,Off,00:00,*
ClientIP 0.0.0.0.255
ClockDaylight 4,0
ClockSetDate 22-04-2015
ClockSetTime 22:08
Debug Off
Plugin 1
Plugin 2
EventlistCount 5,250
FreeMem 2434
HWConfig 0x400BE737
HWStatus 0x4003E337
HTTPHost qnap.local/nodo/nodo.php
ID DR8AWT1K
IP 0.0.0.0.0(DHCP)
Log Off
Output HTTP,On
PortInput 6636
PortOutput 80
RawSignalReceive Off,On
Temp
WiredAnalog 1,1022
WiredAnalog 2,1022
WiredAnalog 3,1022
WiredAnalog 4,1022
WiredAnalog 5,1022
WiredAnalog 6,1022
WiredAnalog 7,1022
WiredAnalog 8,1022
WiredIn 1,On
WiredIn 2,On
WiredIn 3,On
WiredIn 4,On
WiredIn 5,On
WiredIn 6,On
WiredIn 7,On
WiredIn 8,On
WiredOut 1,Off
WiredOut 2,Off
WiredOut 3,Off
WiredOut 4,Off
WiredOut 5,Off
WiredOut 6,Off
WiredOut 7,Off
WiredOut 8,Off
WiredPullup 1,On
WiredPullup 2,On
WiredPullup 3,On
WiredPullup 4,On
WiredPullup 5,On
WiredPullup 6,On
WiredPullup 7,On
WiredPullup 8,On
WiredSmittTrigger 1,10
WiredSmittTrigger 2,10
WiredSmittTrigger 3,10
WiredSmittTrigger 4,10
WiredSmittTrigger 5,10
WiredSmittTrigger 6,10
WiredSmittTrigger 7,10
WiredSmittTrigger 8,10
WiredThreshold 1,512
WiredThreshold 2,512
WiredThreshold 3,512
WiredThreshold 4,512
WiredThreshold 5,512
WiredThreshold 6,512
WiredThreshold 7,512
WiredThreshold 8,512
RawSignalSample 25
AliasShow Off
Build 809
WaitBusyNodo Off
!******************************************************************************!


Dit is wat ik continu in putty zie verschijnen
    >>Input=System; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.
    Output=HTTP; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.

Heb je mogelijk een idee welke instelling er mis gaat wat betreft communicatie??


HostIP mist in jou status overzicht. Dit betekend dat de Nodo het dns record qnap.local niet kan omzetten naar een IP-adres.

Onderstaand mijn status
!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R808, ThisUnit=1, ID=MARTIN
Date=22-04-2015 (Wed); Time=23:03 DaylightSaving
IP=192.168.100.10, PortOutput=80, PortInput=6636
Host=www.nodo-domotica.nl, HostIP=185.10.51.106
!******************************************************************************!
Klopt de url qnap.local/nodo/nodo.php wel? met andere woorden wat gebeurd er als je http://qnap.local/nodo/nodo.php in je browser invoerd?

Tevens vind ik de instelling IP 0.0.0.0.0(DHCP) in jou status overzicht ook vreemd. Hier zou een geldig ip-adres moeten staan. Wellicht een probleem in build 809!? Ik draai zelf met 808
Laatst bijgewerkt door mdegraaf op 22 apr 2015, 22:11, in totaal 1 keer bewerkt.
mdegraaf
 
Berichten: 81
Geregistreerd: 18 okt 2011, 22:03

Re: WebApp code beschikbaar

Berichtdoor mdegraaf » 22 apr 2015, 21:58

kabouter schreef:
mdegraaf schreef:
kabouter schreef:zover ik weet kan ik dat wel van binnenuit benaderen heb ook nog andere port mapping staan zoals Domotics en andere apps en IP camera's .
maar ik weet zo niet of het aan de Synology 212J nas kan liggen.


Als ik de pagina http://vanderaa.dyndns.tv/webapp/api/ open zie ik de tekst "Goeden avond, welkom bij Kabouterhuis" hier gaat in ieder geval iets mis. Indien je de pagina http://vanderaa.dyndns.tv/webapp opent krijg je dan een login pagina te zien?


Zo te zien kom ik dus met http://vanderaa.dyndns.tv/webapp/api/ in mijn hoofdpagina uit.
dus zou ik alles in de root moeten plaatsen. ( liever niet.)
Als ik http://vanderaa.dyndns.tv/webapp open kom ik inderdaad gewoon bij het inlog pagina.
kan ik dit opvangen door in path.js deze pad aan te geven ?


heb path.js aangepast en nu laat ie met http://vanderaa.dyndns.tv/webapp/api/ bij mij wel iets anders zie.API commands ... lijkt nu wel goed te gaan.
Nu nog ff wat hobby-en met het een en ander. of zit ik nu op een verkeerde spoor? :oops:


path.js heeft niets te maken met /api. De variable path in path.js welke in /js staat moet leeg zijn. Indien je kunt inloggen dan werkt de Web App in ieder geval goed.
mdegraaf
 
Berichten: 81
Geregistreerd: 18 okt 2011, 22:03

Re: WebApp code beschikbaar

Berichtdoor RonEN » 25 apr 2015, 09:08

mdegraaf schreef:
RonEN schreef:
mdegraaf schreef:Dag Martin,

Werkt bijna goed, echter als ik naar Setup ga in het menu krijg ik de fout HTTP-fout 500 "Kan de pagina niet weergeven"
In mijn adresbalk staat : http://192.168.5.23/webapp/admin

De overige menu's lijken wel gewoon te werken. In tegenstelling tot de reacties hierboven heb ik in de header "No connection to Nodo!" (wat klopt) en in de footer de tijd.

Enig idee ?


En als je http://192.168.5.23/webapp/admin/index.html probeert?

Nee dan krijg ik dezelfde melding.

Ik weet niet of het helpt, maar ik draai de webapp op een Synology. Heb Curl en mod_rewrite niet ingeschakeld omdat ik niet kan vinden hoe, mocht dit al nodig zijn op een Synology.


Is de synology publiek te benaderen zodat ik eens kan kijken waar het mis gaat?


Martin, heb een bericht in je postbus gezet.
RonEN
 
Berichten: 19
Geregistreerd: 30 maart 2015, 17:44

Re: WebApp code beschikbaar

Berichtdoor Vincent » 25 apr 2015, 09:43

Vincent schreef:
mdegraaf schreef:
Vincent schreef:
Martin,

Ben hier opnieuw vanaf 0 begonnen op de RPI met de nieuwe versie en jouw stappenplan. Helaas is het resultaat precies hetzelfde dan bij Andreo (en dus zoals in de screenshot die ik eerder postte).

Zelf werk ik met Lighttpd ipv Apache. Ik zie dat curl en rewrite enabled zijn, maar ik vind nergens terug hoe ik onder Lighttpd de module headers kan activeren ... Zou het gebrek aan die headers module het probleem zijn ? Kan je mij/ons op weg helpen om deze alsnog te activerenninder Lighttpd ?

Dank en groeten,
Vincent.

Edit: op aangeven van onderstaande site mod_setenv geactiveerd ... zonder resultaat ...

http://wiki.nginx.org/ModuleComparisonMatrix


Hoi Vincent,

Lighthttpd heb ik zelf geen ervaring mee maar de Web App is in ieder geval afhankelijk van /api met daarin de .htaccess config. De headers module wordt in het geval van de Web App gebruikt voor CORS. Met andere woorden, de API kan ook vanaf externe locaties worden benaderd. Mocht het probleem aan de headers module liggen dan kun je deze afhankelijkheid uitschakelen door onderstaande stappen uit te voeren.

1) open .htaccess in de map /api
2) zet een # voor of verwijder de regels
Header add Access-Control-Allow-Origin "*"
Header add Access-Control-Allow-Headers "origin, x-requested-with, content-type, authorization"
Header add Access-Control-Allow-Methods "PUT, GET, POST, DELETE, OPTIONS"
3) open index.php in de map /api
4) verwijder regels 3 t/m 11 (zie onderstaande code)
if ($_SERVER['REQUEST_METHOD'] == 'OPTIONS') {
// return only the headers and not the content
// only allow CORS if we're doing a GET - i.e. no saving for now.
if (isset($_SERVER['HTTP_ACCESS_CONTROL_REQUEST_METHOD']) && $_SERVER['HTTP_ACCESS_CONTROL_REQUEST_METHOD'] == 'GET') {
header('Access-Control-Allow-Origin: *');
header('Access-Control-Allow-Headers: origin, x-requested-with, content-type, authorization');
}
exit;
}


Dank voor het antwoord. Heb het zo geprobeerd maar het verandert helaas niets. Ik blijf het scherm met bovenaan "undefined" krijgen (cfr screenshot die ik postte) ...
Tenzij iemand iets beter kan bedenken zal ik eens lighttpd vervangen door apache op de RPI ...


Martin,

Na de switch naar Apache2 (met headers en rewrite enabled) is het resultaat helaas nog steeds hetzelfde (scherm met bovenaan "undefined" en geen mogelijkheid tot inloggen).

Als ik de webapp upload naar mijn shared hosting krijg ik wel gewoon een login scherm ...

Nog tips ?

Mvg
Vincent.
Vincent
 
Berichten: 26
Geregistreerd: 17 feb 2015, 22:05

Re: WebApp code beschikbaar

Berichtdoor mdegraaf » 26 apr 2015, 19:34

Vincent schreef:Martin,

Na de switch naar Apache2 (met headers en rewrite enabled) is het resultaat helaas nog steeds hetzelfde (scherm met bovenaan "undefined" en geen mogelijkheid tot inloggen).

Als ik de webapp upload naar mijn shared hosting krijg ik wel gewoon een login scherm ...

Nog tips ?

Mvg
Vincent.


Is de web app publiek te benaderen zodat ik even mee kan kijken waar het fout gaat?
mdegraaf
 
Berichten: 81
Geregistreerd: 18 okt 2011, 22:03

Re: WebApp code beschikbaar

Berichtdoor andreo » 26 apr 2015, 22:42

mdegraaf schreef:
andreo schreef:Martin,

De nieuwe webapp versie draait nu lokaal op een QNap na de aanpassing van de mod_headers, nu heb ik geprobeerd een NES via een automatische config te koppelen met de webapp echter zonder succes.
Uiteindelijk heb ik de NES geprogrammeerd met de laatste Nodo software op github (3.8 build 809) en het nogmaals via de auto config procedure geprobeerd, na het invullen van het Nodo IP adres en een wachtwoord en het vinkje Auto Config wordt de NES geprogrammeerd (dit kan ik zien via een putty sessie op het LAN) en dan geeft de webapp aan dat de registratie correct is verlopen echter blijft er in de webapp staan dat er GEEN connect met de NES is.

Hieronder een weergave van status all
*** VERWIJDERD***

Dit is wat ik continu in putty zie verschijnen
    >>Input=System; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.
    Output=HTTP; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.

Heb je mogelijk een idee welke instelling er mis gaat wat betreft communicatie??


HostIP mist in jou status overzicht. Dit betekend dat de Nodo het dns record qnap.local niet kan omzetten naar een IP-adres.

Onderstaand mijn status
!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R808, ThisUnit=1, ID=MARTIN
Date=22-04-2015 (Wed); Time=23:03 DaylightSaving
IP=192.168.100.10, PortOutput=80, PortInput=6636
Host=www.nodo-domotica.nl, HostIP=185.10.51.106
!******************************************************************************!
Klopt de url qnap.local/nodo/nodo.php wel? met andere woorden wat gebeurd er als je http://qnap.local/nodo/nodo.php in je browser invoerd?

Tevens vind ik de instelling IP 0.0.0.0.0(DHCP) in jou status overzicht ook vreemd. Hier zou een geldig ip-adres moeten staan. Wellicht een probleem in build 809!? Ik draai zelf met 808


Hoi Martin,

Ik heb de Qnap op DHCP gezet en nu kan ik pingen naar QNAP en krijg daarna keurig ook het IP te zien.




Ik heb in de settings.php het volgende geplaatst

    //Web App
    //-------------------------------------
    $NODO_URL = "qnap/nodo/nodo.php"; //Deze waarde zal in de Nodo onder HTTPhost worden gezet bij een auto config. Http:// zal door de Nodo worden toegevoegd. Https:// wordt NIET door de Nodo ondersteund!
    $WEBAPP_URL = "qnap/nodo/"; //URL van de Web App
    $SALT = "3OvxO0Qi594v10bhu6DC3g2XG3ZozJsH"; //$SALT word gebruikt om er voor te zorgen dat ook slecht gekozen wachtwoorden zoals 1234, abc sterk worden gehashed. Let op indien je deze waarde aanpast werkt het standaard wachtwoord niet meer!

    //-------------------------------------

Na het opzetten van de communicatie vult de Nodo zich met onderstaande

Code: Selecteer alles
Enter your password: XXXXXXXX

!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R813, ThisUnit=1, ID=912PTD5G
Date=26-04-2015 (Sun); Time=23:36 DaylightSaving
IP=192.168.1.74, PortOutput=80, PortInput=6636
Host=qnap
!******************************************************************************!
>status all
Input=Terminal; Unit=1; Event=Status All,0

!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R813, ThisUnit=1, ID=912PTD5G
Date=26-04-2015 (Sun); Time=23:36 DaylightSaving
IP=192.168.1.74, PortOutput=80, PortInput=6636
Host=qnap
!******************************************************************************!
AlarmSet 1,Off,00:00,*
AlarmSet 2,Off,00:00,*
AlarmSet 3,Off,00:00,*
AlarmSet 4,Off,00:00,*
AlarmSet 5,Off,00:00,*
AlarmSet 6,Off,00:00,*
AlarmSet 7,Off,00:00,*
AlarmSet 8,Off,00:00,*
ClientIP 0.0.0.0.255
ClockDaylight 4,0
ClockSetDate 26-04-2015
ClockSetTime 23:36
Debug Off
Plugin 1
Plugin 2
Plugin 5
Plugin 6
Plugin 20
Plugin 23
EventlistCount 5,250
FreeMem 2361
HWConfig 0x400BE737
HWStatus 0x4003E337
HTTPHost qnap/nodo/nodo.php
ID 912PTD5G
IP 0.0.0.0.0(DHCP)
Log Off
Output HTTP,On
PortInput 6636
PortOutput 80
RawSignalReceive Off,On
Temp
WiredAnalog 1,1022
WiredAnalog 2,1022
WiredAnalog 3,1022
WiredAnalog 4,1022
WiredAnalog 5,1022
WiredAnalog 6,1022
WiredAnalog 7,1022
WiredAnalog 8,1022
WiredIn 1,On
WiredIn 2,On
WiredIn 3,On
WiredIn 4,On
WiredIn 5,On
WiredIn 6,On
WiredIn 7,On
WiredIn 8,On
WiredOut 1,Off
WiredOut 2,Off
WiredOut 3,Off
WiredOut 4,Off
WiredOut 5,Off
WiredOut 6,Off
WiredOut 7,Off
WiredOut 8,Off
WiredPullup 1,On
WiredPullup 2,On
WiredPullup 3,On
WiredPullup 4,On
WiredPullup 5,On
WiredPullup 6,On
WiredPullup 7,On
WiredPullup 8,On
WiredSmittTrigger 1,10
WiredSmittTrigger 2,10
WiredSmittTrigger 3,10
WiredSmittTrigger 4,10
WiredSmittTrigger 5,10
WiredSmittTrigger 6,10
WiredSmittTrigger 7,10
WiredSmittTrigger 8,10
WiredThreshold 1,512
WiredThreshold 2,512
WiredThreshold 3,512
WiredThreshold 4,512
WiredThreshold 5,512
WiredThreshold 6,512
WiredThreshold 7,512
WiredThreshold 8,512
RawSignalSample 25
AliasShow Off
Build 813
WaitBusyNodo Off
!******************************************************************************!
>>Input=System; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.
Output=RF; Unit=0; Event=Message 6,0: Unable to establish TCP/IP connection.
Output=HTTP; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.


nog steeds zie ik geen IP adres achter de host staan. En IP 0.0.0.0 staat toch voor DHCP?

Het ingeven van qnap/nodo/nodo.php levert een blanco pagina op.
Laatst bijgewerkt door andreo op 25 okt 2015, 23:19, in totaal 1 keer bewerkt.
Groet, Andre
mijn NES
Nodo-Mega V3.7 R744|Nodo-Mini V3.7 R744|WebApp lokaal QNAP TS-119P II (SWINWA-PROD-V099)|WS-3500|ASUN650 zonweringsmodule | diverse KAKU |
andreo
 
Berichten: 119
Geregistreerd: 17 sep 2012, 23:51
Woonplaats: Anna Paulowna

Re: WebApp code beschikbaar

Berichtdoor mdegraaf » 28 apr 2015, 19:12

andreo schreef:
mdegraaf schreef:
andreo schreef:Martin,

De nieuwe webapp versie draait nu lokaal op een QNap na de aanpassing van de mod_headers, nu heb ik geprobeerd een NES via een automatische config te koppelen met de webapp echter zonder succes.
Uiteindelijk heb ik de NES geprogrammeerd met de laatste Nodo software op github (3.8 build 809) en het nogmaals via de auto config procedure geprobeerd, na het invullen van het Nodo IP adres en een wachtwoord en het vinkje Auto Config wordt de NES geprogrammeerd (dit kan ik zien via een putty sessie op het LAN) en dan geeft de webapp aan dat de registratie correct is verlopen echter blijft er in de webapp staan dat er GEEN connect met de NES is.

Hieronder een weergave van status all
*** VERWIJDERD***

Dit is wat ik continu in putty zie verschijnen
    >>Input=System; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.
    Output=HTTP; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.

Heb je mogelijk een idee welke instelling er mis gaat wat betreft communicatie??


HostIP mist in jou status overzicht. Dit betekend dat de Nodo het dns record qnap.local niet kan omzetten naar een IP-adres.

Onderstaand mijn status
!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R808, ThisUnit=1, ID=MARTIN
Date=22-04-2015 (Wed); Time=23:03 DaylightSaving
IP=192.168.100.10, PortOutput=80, PortInput=6636
Host=www.nodo-domotica.nl, HostIP=185.10.51.106
!******************************************************************************!
Klopt de url qnap.local/nodo/nodo.php wel? met andere woorden wat gebeurd er als je http://qnap.local/nodo/nodo.php in je browser invoerd?

Tevens vind ik de instelling IP 0.0.0.0.0(DHCP) in jou status overzicht ook vreemd. Hier zou een geldig ip-adres moeten staan. Wellicht een probleem in build 809!? Ik draai zelf met 808


Hoi Martin,

Ik heb de Qnap op DHCP gezet en nu kan ik pingen naar QNAP en krijg daarna keurig ook het IP te zien.




Ik heb in de settings.php het volgende geplaatst

    //Web App
    //-------------------------------------
    $NODO_URL = "qnap/nodo/nodo.php"; //Deze waarde zal in de Nodo onder HTTPhost worden gezet bij een auto config. Http:// zal door de Nodo worden toegevoegd. Https:// wordt NIET door de Nodo ondersteund!
    $WEBAPP_URL = "qnap/nodo/"; //URL van de Web App
    $SALT = "3OvxO0Qi594v10bhu6DC3g2XG3ZozJsH"; //$SALT word gebruikt om er voor te zorgen dat ook slecht gekozen wachtwoorden zoals 1234, abc sterk worden gehashed. Let op indien je deze waarde aanpast werkt het standaard wachtwoord niet meer!

    //-------------------------------------

Na het opzetten van de communicatie vult de Nodo zich met onderstaande

Code: Selecteer alles
Enter your password: qwe45ty

!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R813, ThisUnit=1, ID=912PTD5G
Date=26-04-2015 (Sun); Time=23:36 DaylightSaving
IP=192.168.1.74, PortOutput=80, PortInput=6636
Host=qnap
!******************************************************************************!
>status all
Input=Terminal; Unit=1; Event=Status All,0

!******************************************************************************!
Nodo Domotica controller V3.8 (Mega)
(c) Copyright 2015 P.K.Tonkes. Licensed under GNU General Public License.
Product=SWACNC-MEGA-R813, ThisUnit=1, ID=912PTD5G
Date=26-04-2015 (Sun); Time=23:36 DaylightSaving
IP=192.168.1.74, PortOutput=80, PortInput=6636
Host=qnap
!******************************************************************************!
AlarmSet 1,Off,00:00,*
AlarmSet 2,Off,00:00,*
AlarmSet 3,Off,00:00,*
AlarmSet 4,Off,00:00,*
AlarmSet 5,Off,00:00,*
AlarmSet 6,Off,00:00,*
AlarmSet 7,Off,00:00,*
AlarmSet 8,Off,00:00,*
ClientIP 0.0.0.0.255
ClockDaylight 4,0
ClockSetDate 26-04-2015
ClockSetTime 23:36
Debug Off
Plugin 1
Plugin 2
Plugin 5
Plugin 6
Plugin 20
Plugin 23
EventlistCount 5,250
FreeMem 2361
HWConfig 0x400BE737
HWStatus 0x4003E337
HTTPHost qnap/nodo/nodo.php
ID 912PTD5G
IP 0.0.0.0.0(DHCP)
Log Off
Output HTTP,On
PortInput 6636
PortOutput 80
RawSignalReceive Off,On
Temp
WiredAnalog 1,1022
WiredAnalog 2,1022
WiredAnalog 3,1022
WiredAnalog 4,1022
WiredAnalog 5,1022
WiredAnalog 6,1022
WiredAnalog 7,1022
WiredAnalog 8,1022
WiredIn 1,On
WiredIn 2,On
WiredIn 3,On
WiredIn 4,On
WiredIn 5,On
WiredIn 6,On
WiredIn 7,On
WiredIn 8,On
WiredOut 1,Off
WiredOut 2,Off
WiredOut 3,Off
WiredOut 4,Off
WiredOut 5,Off
WiredOut 6,Off
WiredOut 7,Off
WiredOut 8,Off
WiredPullup 1,On
WiredPullup 2,On
WiredPullup 3,On
WiredPullup 4,On
WiredPullup 5,On
WiredPullup 6,On
WiredPullup 7,On
WiredPullup 8,On
WiredSmittTrigger 1,10
WiredSmittTrigger 2,10
WiredSmittTrigger 3,10
WiredSmittTrigger 4,10
WiredSmittTrigger 5,10
WiredSmittTrigger 6,10
WiredSmittTrigger 7,10
WiredSmittTrigger 8,10
WiredThreshold 1,512
WiredThreshold 2,512
WiredThreshold 3,512
WiredThreshold 4,512
WiredThreshold 5,512
WiredThreshold 6,512
WiredThreshold 7,512
WiredThreshold 8,512
RawSignalSample 25
AliasShow Off
Build 813
WaitBusyNodo Off
!******************************************************************************!
>>Input=System; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.
Output=RF; Unit=0; Event=Message 6,0: Unable to establish TCP/IP connection.
Output=HTTP; Unit=1; Event=Message 6,0: Unable to establish TCP/IP connection.


nog steeds zie ik geen IP adres achter de host staan. En IP 0.0.0.0 staat toch voor DHCP?

Het ingeven van qnap/nodo/nodo.php levert een blanco pagina op.


Wil je de laatste Web App versie welke ik net op GIT heb gezet eens proberen.
Ik realiseer me net dat er wijzigingen in de Nodo core zijn gemaakt wat betreft het resolven van ip-adressen en er hiervoor in de Web App ook aanpassingen zijn gemaakt. Deze aanpassingen stonden nog niet op Github
mdegraaf
 
Berichten: 81
Geregistreerd: 18 okt 2011, 22:03

VorigeVolgende

Keer terug naar Nodo WebApp

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers. en 2 gasten

cron