nodo-domotica.nl

pir sensor klappert

Hier kan gediscussieerd worden over sensoren, electronica problemen, componenten, etc.

pir sensor klappert

Berichtdoor bryan241 » 18 jun 2012, 09:06

Ik gebruik een PIR sensor om een relais aan te sturen, maar zodra het relais uitschakelt geeft de PIR sensor onterecht weer een puls, waardoor het relais weer aan schakelt. Het relais schakelt overigens uit door middel van een timer, zodat de pir sensor veel eerder alweer een lage waarde geeft aan de arduino.
Ik voed de PIR sensor en het relais vanuit de arduino en heb een externe voeding aangesloten op de arduino om een stabiele 5 volt te verkrijgen.

Zonder relais gaat het wel goed (als ik de poort monitor zie ik alleen een puls als er beweging is).

Ik gebruik het relais met een bc547 transistor en een 1k weerstand op de basis en een diode over de pootjes van het relais.

Heeft iemand een idee hoe ik dit eventueel kan oplossen?
bryan241
 
Berichten: 172
Geregistreerd: 07 jan 2012, 14:14

Re: pir sensor klappert

Berichtdoor bryan241 » 19 jun 2012, 10:07

Het gebeurd bij het schakelen van het relais. Zonder relais gaat het goed.
Ik moet het relais dus onafhankelijk gaan voeden. Dit lijkt me een beetje overdone...

Suggesties zijn welkom.
bryan241
 
Berichten: 172
Geregistreerd: 07 jan 2012, 14:14

Re: pir sensor klappert

Berichtdoor Flippo765 » 05 jun 2014, 22:44

Heb je al een idee waar dit aan kan liggen?

Ik heb namelijk hetzelfde probleem, ik heb een sensor met led-verlichting op de WC.
De sensor voedt ik de arduino in en met een wiredthresshold wil ik de led verlichting (fade) laten schakelen.
Dat schakelen lukt prima met de RBG plugin maar de PIR geeft op de Nodo constant een andere waarde tussen de 600 het 60, dit lijkt mij het onjuist schakelen van de sensor.
Flippo765
 
Berichten: 96
Geregistreerd: 24 nov 2011, 22:31

Re: pir sensor klappert

Berichtdoor manjh » 06 jun 2014, 11:09

Je moet gewoon even een goeie kantelwaarde zoeken, en die instellen met WiredThreshold. Denk ook even aan de SmittTrigger waarde.
Op die manier voorkom je het flipfloppen.
Hans
manjh
 
Berichten: 1173
Geregistreerd: 29 aug 2011, 14:39

Re: pir sensor klappert

Berichtdoor Flippo765 » 06 jun 2014, 11:38

Dat begrijp ik, alleen schommelt de waarde constant tussen de 40 en 600, ook als we niet in de ruimte komen.
Even een screenshot om te laten zien wat ik bedoel:
Afbeelding
http://i1217.photobucket.com/albums/dd393/Flippo765/PIRwc_zps34b348cf.jpg

De PIR is er een met 2 instelbare potmeters, (sensitivity en time) deze al in alle standen geprobeerd, ook heb ik diverse andere USB voedingen geprobeerd op de mega.

Kan het misschien zijn dat de spanning die uit de Mega op het breadboard komt instabiel is of storingen met zich meebrengt?

Datablad PIR:
http://www.docstoc.com/docs/134947604/Document-PIR-Motion-Detector-Module-DYP-ME003-is-a-pyroelectric-sensor-module-which-developed-for-human-body-detection
Flippo765
 
Berichten: 96
Geregistreerd: 24 nov 2011, 22:31


Keer terug naar De electronica hoek

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers. en 1 gast

cron