nodo-domotica.nl

433Mhz signaal koppelen aan UserEvent

Met de Nodo commando's en dee Eventlist kun je vrijwel elke domotica wens realiseren. De Nodo beschikt hiervoor over een eigen script-taal waarmee u uw domotica wensen kunt realiseren. Plaats hier uw vragen en tips die hier op betrekking hebben.

433Mhz signaal koppelen aan UserEvent

Berichtdoor jellevdl » 25 maart 2012, 19:46

Ook ik ben sinds kort in het bezit van de Nodo en tot nu toe uitermate tevreden!

Ik heb de nodo aangeschaft om eigenlijk alles via mijn Logitech Harmony 1100 te bedienen (in de toekomst met een ipad)
Nu krijg ik al mijn kaku's prima aan de gang met de nodo en nodobeheertool. Ik ben beschik inmiddels over elektrische gordijnen met een 433mhz zender/ontvanger, nu wil ik deze graag met mijn harmony bedienen. Nu begrijp ik dat ik dit signaal kan opvangen, kopieren en aan een userevent kan hangen, ik heb eigenlijk geen idee hoe!

Aangezien ik niet echt een programmeur ben heb ik tot nu toe alles met de nodobeheer tool gedaan, eventghost wel geinstalleerd met de juiste plugin maar hier begrijp ik nog weinig van...
Zou iemand mij in een aantal stappen kunnen uitleggen hoe ik dit voor elkaar kan krijgen?
jellevdl
 
Berichten: 11
Geregistreerd: 16 maart 2012, 15:41

Re: 433Mhz signaal koppelen aan UserEvent

Berichtdoor jellevdl » 28 maart 2012, 12:32

Niemand die dit weet? :|
jellevdl
 
Berichten: 11
Geregistreerd: 16 maart 2012, 15:41

Re: 433Mhz signaal koppelen aan UserEvent

Berichtdoor jellevdl » 01 apr 2012, 09:15

Inmiddels (voor mijn gevoel) weer een stapje verder, heb onderstaande signalen via RawSignalGet in Evenghost weten te achterhalen, als ik deze signalen meteen via RawSignalPut probeer te versturen gebeurd er niets, wat doe ik fout?

Dicht:
> RawSignal=0x337,188,0x38B,187,0x38C,200,0x370,179,0x38E,195,0x393,161,0x11E,0x34A,226,
0x335,0x11E,0x323,0x10E,0x332,0x3AE,158,0x37E,200,0x388,175,0x393,177,0x10E,0x32E,
0x388,193,0x119,0x336,0x10D,0x320,0x38B,187,0x374,212,0x101,0x33D,0x112,0x342,249,
0x34C,245,0x349,249,0

Stop:
> RawSignal=0x3AB,186,0x391,177,0x38E,180,0x37A,199,0x383,182,0x386,189,0x107,0x33B,
0x10D,x333,0x113,0x326,0x11E,0x322,0x387,187,0x39E,164,0x393,170,0x392,180,255,0x342,
0x386,191,252,0x33C,0x105,0x33C,0x118,0x329,0x113,0x32C,0x11E,0x31D,0x11E,0x326,0x388,
189,0x393,172,0x10B,0

Open:
> RawSignal=0x3A5,199,0x386,193,0x37F,200,0x37F,193,0x37E,201,0x37C,202,0x103,0x340,
0x108,0x335,0x108,0x33A,0x10F,0x333,0x380,201,0x380,192,0x37C,206,0x376,208,249,0x349,
0x374,206,0x102,0x342,0x103,0x33F,0x105,0x33C,0x103,0x33B,0x37B,204,0x379,205,0x101,
0x345,248,0x346,0x106,0
jellevdl
 
Berichten: 11
Geregistreerd: 16 maart 2012, 15:41

Re: 433Mhz signaal koppelen aan UserEvent

Berichtdoor Paul » 01 apr 2012, 12:53

jellevdl schreef:Inmiddels (voor mijn gevoel) weer een stapje verder, heb onderstaande signalen via RawSignalGet in Evenghost weten te achterhalen, als ik deze signalen meteen via RawSignalPut probeer te versturen gebeurd er niets, wat doe ik fout?

Dicht:
> RawSignal=0x337,188,0x38B,187,0x38C,200,0x370,179,0x38E,195,0x393,161,0x11E,0x34A,226,
0x335,0x11E,0x323,0x10E,0x332,0x3AE,158,0x37E,200,0x388,175,0x393,177,0x10E,0x32E,
0x388,193,0x119,0x336,0x10D,0x320,0x38B,187,0x374,212,0x101,0x33D,0x112,0x342,249,
0x34C,245,0x349,249,0

Stop:
> RawSignal=0x3AB,186,0x391,177,0x38E,180,0x37A,199,0x383,182,0x386,189,0x107,0x33B,
0x10D,x333,0x113,0x326,0x11E,0x322,0x387,187,0x39E,164,0x393,170,0x392,180,255,0x342,
0x386,191,252,0x33C,0x105,0x33C,0x118,0x329,0x113,0x32C,0x11E,0x31D,0x11E,0x326,0x388,
189,0x393,172,0x10B,0

Open:
> RawSignal=0x3A5,199,0x386,193,0x37F,200,0x37F,193,0x37E,201,0x37C,202,0x103,0x340,
0x108,0x335,0x108,0x33A,0x10F,0x333,0x380,201,0x380,192,0x37C,206,0x376,208,249,0x349,
0x374,206,0x102,0x342,0x103,0x33F,0x105,0x33C,0x103,0x33B,0x37B,204,0x379,205,0x101,
0x345,248,0x346,0x106,0


Dag jelle,

Kun je even aangeven welke Nodo versie en welke arduino je gebruikt?
Groeten Paul
Paul
 
Berichten: 1152
Geregistreerd: 31 aug 2011, 20:33

Re: 433Mhz signaal koppelen aan UserEvent

Berichtdoor jellevdl » 02 apr 2012, 08:28

Dag jelle,

Kun je even aangeven welke Nodo versie en welke arduino je gebruikt?


Hoi Paul, heb een Arduino Uno met compiler 0023 en een Nodo Shield V1.2
met de laatste software versie.
jellevdl
 
Berichten: 11
Geregistreerd: 16 maart 2012, 15:41

Re: 433Mhz signaal koppelen aan UserEvent

Berichtdoor Paul » 02 apr 2012, 10:23

jellevdl schreef:
Dag jelle,

Kun je even aangeven welke Nodo versie en welke arduino je gebruikt?


Hoi Paul, heb een Arduino Uno met compiler 0023 en een Nodo Shield V1.2
met de laatste software versie.

Krijg je bij het indrukken van een knop steeds dezelfde hex-codes te zien?
Groeten Paul
Paul
 
Berichten: 1152
Geregistreerd: 31 aug 2011, 20:33

Re: 433Mhz signaal koppelen aan UserEvent

Berichtdoor jellevdl » 02 apr 2012, 11:32

Paul schreef:
jellevdl schreef:
Dag jelle,

Kun je even aangeven welke Nodo versie en welke arduino je gebruikt?


Hoi Paul, heb een Arduino Uno met compiler 0023 en een Nodo Shield V1.2
met de laatste software versie.

Krijg je bij het indrukken van een knop steeds dezelfde hex-codes te zien?


Dit zou ik vanavond even moeten checken, zou het een rolling code kunnen zijn?

Als ik een de code meteen wil verzenden met RawSignalPut dan gaat het rode status ledje ook niet branden, dit lijkt me niet te kloppen?
jellevdl
 
Berichten: 11
Geregistreerd: 16 maart 2012, 15:41

Re: 433Mhz signaal koppelen aan UserEvent

Berichtdoor jellevdl » 04 apr 2012, 08:37

Ik heb nogmaals de codes opgehaald met RawSignalGet en krijg nu de volgende codes:

Open:
> RawSignal=0x3AF,192,0x383,191,0x381,200,0x37C,206,0x37E,202,0x37E,196,0x105,
0x342,0x107,0x33C,0x102,0x343,0x102,0x33B,0x37C,205,0x37C,207,0x37C,204,0x379,
204,0x102,0x345,0x379,206,0x100,0x346,249,0x346,0x105,0x340,0x10C,0x339,0x37C,
207,0x37A,199,0x105,0x341,0x107,0x33F,0x100,0

Stop:
> RawSignal=0x3A1,212,0x36F,205,0x374,206,0x373,217,0x369,217,0x36F,217,243,0x34D,
243,0x34C,245,0x34E,245,0x34A,0x370,211,0x36C,213,0x36F,217,0x373,211,234,0x35A,
0x369,213,246,0x353,238,0x34C,245,0x34D,246,0x34E,250,0x346,0x105,0x340,0x381,194,
0x372,212,0x101,0

Dicht:
> RawSignal=0x3CF,153,0x38C,183,0x388,199,0x37F,193,0x382,194,0x375,207,252,0x343,
0x106,0x336,0x103,0x33D,0x105,0x33A,0x380,205,0x37A,189,0x387,193,0x372,213,255,
0x345,0x36F,210,0x10D,0x32E,0x110,0x333,0x376,211,0x37C,202,250,0x345,0x109,0x337,
0x107,0x33A,0x10C,0x336,0x105,0

De code lijkt nu anders te zijn, is dit dan een rolling code?
Vreemd is dan wel dat als ik mij originele tv afstandbediening pak en hiervan de code van een willekeurige toets bekijk, deze ook veranderd...

Paul, zou je mij op weg kunnen helpen? alvast bedankt!
jellevdl
 
Berichten: 11
Geregistreerd: 16 maart 2012, 15:41

Re: 433Mhz signaal koppelen aan UserEvent

Berichtdoor Paul » 05 apr 2012, 10:06

Iedere keer als je dezelfde knop indrukt moet je altijd steeds dezelfde code terug krijgen. deze info heb ik echt nodig want het is een voorwaarde om het werkend te krijgen. is dit niet het geval, dan moeten we het anders aanpakken.

Het gaat mij hier om de hex-code bv. 0x12345678 en niet om de pulsenreeks.

Doe eerst even deze test.
Groeten Paul
Paul
 
Berichten: 1152
Geregistreerd: 31 aug 2011, 20:33

Re: 433Mhz signaal koppelen aan UserEvent

Berichtdoor Petervd » 07 jun 2012, 20:09

Zie dat het even stil is in dit onderwerp, nu heb ik hier toevallig een vraag over:

Is er een mogelijkheid om de data die een bepaald RF event genereert (tijdelijk) te loggen, ik zie nl bij mij keurig de signalen van de weerunits voorbij komen, en ben benieuwd of hier soms wat mee te doen is.

hieronder een voorbeeld

Date=2012-06-07 (Wed), Time=20:59, Input=RF, Unit=15, Event=0x7FFFFFFF

(betreft geen ruis, interval van 40 sec, loopt keurig in sync met de weerunit)


gr Peter
Petervd
 
Berichten: 34
Geregistreerd: 01 dec 2011, 16:25


Keer terug naar Nodo scripts

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers. en 2 gasten